You are not logged in.

#1 2014-06-09 17:48:13

mcdermd
Member
From: Corvallis, OR
Registered: 2014-05-12
Posts: 973
Website

Beige G3 with a failed IDE bus?

We pulled the G3 desktop out of storage to do some testing and it wouldn't boot. The hard drive and CD-ROM both made some running noises but neither sound "normal". We did the usual first aid of Cuda/PRAM resets to no avail. Swapped PSUs, IDE cables and drives. I don't see any bad leaks or burns on the logic board.

Has anyone else seen a G3 that 'tattered its IDE? Has anyone brought one back?


Daily Drivers: 27" iMac 2.8 GHz Quad-Core i7 (Late 2009), 21.5" iMac 2.7GHz Quad-Core i5 (Late 2013), 11" Macbook Air 1.6 GHz i5 (Mid-2011)
See the restored heroes here.

Offline

#2 2014-06-09 18:29:06

iMic
Administrator
From: Adelaide, Australia
Registered: 2014-05-12
Posts: 895
Website

Re: Beige G3 with a failed IDE bus?

I had a Beige G3 Desktop a few years back that did exactly this. I ended up throwing in a SCSI card and running the machine exclusively from SCSI drives. Not the most ideal solution, but it worked.

Would also be interested to know if this is a common occurrence.


Resident Professor of Alternative Methodology
Faculty of Macintosh Restorations & Modifications - "It works, let's fix it!"

Offline

#3 2014-06-09 21:19:22

LCGuy
Administrator
From: Sydney, Australia
Registered: 2014-05-13
Posts: 822

Re: Beige G3 with a failed IDE bus?

Never seen an IDE bus fail on a G3, but I have two Beige motherboards both with one bum RAM slot.

Offline

#4 2014-06-10 00:46:47

techknight
Member
Registered: 2014-05-22
Posts: 452

Re: Beige G3 with a failed IDE bus?

are there any BGA chips on the logic board? I cant remember. If so, they may need to be reflown.

Offline

#5 2014-06-10 01:22:25

macdrone
Member
From: Rainier, Or
Registered: 2014-05-25
Posts: 237

Re: Beige G3 with a failed IDE bus?

The beige G3 has scsi and IDE and likes to look for scsi to boot from first. Booting from cd rom after Cuda switch and choosing the system folder on the hard drive made mine come back.  VRM being iffy made the issue worse.

Offline

#6 2014-06-10 05:49:12

mcdermd
Member
From: Corvallis, OR
Registered: 2014-05-12
Posts: 973
Website

Re: Beige G3 with a failed IDE bus?

Mine won't boot from CD either. The CD spins up, then down a couple times and stops. I've tried a couple of different drives.

I don't believe there are any BGAs, just surface mount legs, techknight.


Daily Drivers: 27" iMac 2.8 GHz Quad-Core i7 (Late 2009), 21.5" iMac 2.7GHz Quad-Core i5 (Late 2013), 11" Macbook Air 1.6 GHz i5 (Mid-2011)
See the restored heroes here.

Offline

#7 2014-06-10 07:14:52

macdrone
Member
From: Rainier, Or
Registered: 2014-05-25
Posts: 237

Re: Beige G3 with a failed IDE bus?

Try holding the c key on boot.  Again the hard drive is being the issue.  At least it was for me.  Unplugging other devices made it better as the VRM at the time was failing.

Offline

#8 2014-06-11 00:21:24

techknight
Member
Registered: 2014-05-22
Posts: 452

Re: Beige G3 with a failed IDE bus?

So they are all QFP/TQFP ICs then, no BGAs. Thats good ;-)

Offline

#9 2014-06-11 00:48:50

ClassicHasClass
Member
From: Electron Alley
Registered: 2014-05-26
Posts: 1,108
Website

Re: Beige G3 with a failed IDE bus?

Can you get into Open Firmware? What devices do you see?

Offline

Board footer

About ThinkClassic

ThinkClassic specialises in the maintenance, repair, restoration and modification of Vintage Apple and Macintosh computers. Ask questions and find answers about classic Apple desktops, laptops, accessories and peripherals.