Announcement

After 5 years serving the vintage Apple enthusiast community, ThinkClassic has been marked for closure and is now in caretaker mode. Please see this thread for further information. Please direct any questions, comments and enquiries about the website, management and ownership to this thread.

You are not logged in.

#1 2014-10-06 03:41:25

Scott Baret
Member
Registered: 2014-05-21
Posts: 184

Loss of Sound on Newer Hardware/OS...Workaround?

I have a feeling some of you are familiar with this issue, so I am going to toss it out there in hopes there is some insight.

I know there was some rework of the sound driver/sound manager around System 7.5 and/or with newer hardware. Some older programs just don't play sounds on the newer hardware, including OS 9 and almost every PPC I've tried.

Here are some examples I can think of offhand (sorry for the abundance of educational titles):

--Midnight Rescue, OutNumbered, other Learning Company programs--no sound or music

--Spell-A-Saurus--speech works but other sounds don't

--Math Blaster Mystery--music doesn't work

--Most stuff with SONG resources won't play music

Any thoughts on a workaround? I'd like to get these running under OS 9 with full sound capability.

I've seen this problem with hardware as old as a 5200 running 7.5.x.

Also, FYI: Most stuff dependent on snd resources works fine, even if the music is sequenced somehow from one note (examples include the Munchers games, Sim Ant, the about box on Banner Mania, and the about box on Disinfectant).

Offline

#2 2014-10-06 12:55:09

markyb
Member
From: Aurora, OH (330)
Registered: 2014-05-16
Posts: 185
Website

Re: Loss of Sound on Newer Hardware/OS...Workaround?

I had this issue with some of the AfterDark modules on OS 8.6. I think it has solely to do with the version of QuickTime that's installed. (if any version is installed)


http://markyb86.weebly.com for some packs of old macintosh wallpapers, desktop patterns, windows wallpapers, sound files, etc.

Offline

#3 2014-10-06 13:49:52

ClassicHasClass
Member
From: Electron Alley
Registered: 2014-05-26
Posts: 1,118
Website

Re: Loss of Sound on Newer Hardware/OS...Workaround?

Do you have the Sound Manager INIT installed?


Machine room (updated for 2019!): http://www.floodgap.com/etc/machines.html

Offline

#4 2014-10-08 03:42:26

Scott Baret
Member
Registered: 2014-05-21
Posts: 184

Re: Loss of Sound on Newer Hardware/OS...Workaround?

Hmm...so these programs work fine on 6.0.x, 7.1, etc without a Sound Manager INIT installed. I know Sound Manager is needed for some newer stuff (I remember it coming with a version of SimCity 2000 that shipped on CD-ROM, which I'm pretty sure is 1.2 offhand), but what's strange is that these programs are pretty old (1989-1993, some older). I got that CD-ROM in 1995 and when I used it on the LC with 7.1 I had as my lone Mac at the time, the programs in question worked with or without Sound Manager installed.

What version should I try? Also, could this be some support that was removed from the System itself during the PPC transition or something?

Anyone out there with these games who could test this for me? I've been pretty busy with work lately so my time for tinkering and even playing around on my own Macs has been slipping away from me!! Oh, the cost of maintaining a social life and work life concurrently!!!

Offline

Board footer

About ThinkClassic

ThinkClassic specialises in the use, maintenance, repair, restoration and modification of vintage computers and peripherals.