You are not logged in.

#1 2019-02-09 03:05:49

Eric672
Member
Registered: 2019-02-09
Posts: 2

SE/30 Floppy Issue

Hi! I recently got my SE/30 logic board recapped and I am having an issue with it reading any floppy disk I put in the drive.  Prior to the recap it wouldn't boot.  Now it boots and I can load/run from the rominator ii and everything appears to be stable...just can't get floppy's to load/read.  I have swapped out the drive with 3 other known working ones as well as the ribbon cable and the system just ejects any inserted disk with question mark floppy icon on the screen.  So at this point I am thinking there has to be an issue on the logic board itself.  I am not great at troubleshooting things on a logic board so any help would be greatly appreciated.

Offline

#2 2019-02-09 07:15:07

mcdermd
Member
From: Corvallis, OR
Registered: 2014-05-12
Posts: 1,020
Website

Re: SE/30 Floppy Issue

IIRC, those Bournes resistor arrays can go bad and cause SCSI and floppy issues. Might be something to check.


Daily Drivers: 27" iMac 2.8 GHz Quad-Core i7 (Late 2009), 21.5" iMac 2.7GHz Quad-Core i5 (Late 2013), 11" Macbook Air 1.6 GHz i5 (Mid-2011)
See the restored heroes here.

Offline

#3 2019-02-16 04:06:02

Eric672
Member
Registered: 2019-02-09
Posts: 2

Re: SE/30 Floppy Issue

mcdermd wrote:

IIRC, those Bournes resistor arrays can go bad and cause SCSI and floppy issues. Might be something to check.


Thanks! I'll try to start troubleshooting in that area.  smile

Offline

Board footer

About ThinkClassic

ThinkClassic specialises in the use, maintenance, repair, restoration and modification of vintage computers and peripherals.