You are not logged in.

#1 2016-07-21 18:33:26

retrobecanes
Member
Registered: 2016-07-21
Posts: 1

System Error ID=02 with Mac 128K

I have been experiencing an issue with my Mac 128K and I was wondering if you guys had seen this before.  Basically when I open certain disks or disk images (either via a internal/external drive or the Floppy Emu), the system crashes with a System Error ID=02, forcing a reboot of the system.  See clues below:

  • The error only occurs when I try to open the disk to view its content, and this both by double-clicking on its icon or by using the File > Open sequence.

  • This error only occurs with certain disks or certain disk images but not with all disks/disk images.  The error is also reproducible at will, i.e. a disk or disk image that generates the error will always generate the error.  For instance, the error/crash will occur all the time with the System 2.0 disk but never with the System 3.2 disk.

  • The error is reproducible from the internal drive, the external drive, and from an externally connected Floppy Emu (in Macintosh floppy emulation mode).

  • Even though a given disk will cause a system crash when trying to view its contents, I am able to boot from the disk and/or run applications from it without problem.

  • I have tried the same disks and disk images on a Mac Plus (with the M0130 drive from the Mac 128K and with the Floppy Emu) and I do not get the error.  Therefore, in my opinion, the problem is not caused by the disks, disk images, or drives.  Ideally I would test this on another Mac 128K but I only have one.

  • When I use a disk that will cause the crash (e.g. system disk v2.0) and double-click on the disk icon, the system appears to be accessing/reading the disk (light flashes on floppy emu) and then crashes.  When I use a disk that doesn't cause the crash (e.g. system disk v3.2) and double-click on the disk icon, the system doesn't access the disk (no flashing light on floppy emu) and the system properly displays the disk contents.

Bad RAM and/or bad Bourns filter come to mind as possible culprits but I am not sure that this is how the system would behave.

Do you have any ideas?

Last edited by retrobecanes (2016-07-21 18:35:31)

Offline

Board footer

About ThinkClassic

ThinkClassic specialises in the maintenance, repair, restoration and modification of Vintage Apple and Macintosh computers. Ask questions and find answers about classic Apple desktops, laptops, accessories and peripherals.