After 5 years serving the vintage Apple enthusiast community, ThinkClassic has been marked for closure and is now in caretaker mode. Please see this thread for further information. Please direct any questions, comments and enquiries about the website, management and ownership to this thread.

You are not logged in.

#1 2016-03-28 04:42:26

MacOS Plus
Registered: 2015-12-09
Posts: 110

Third-party dual-CPU upgrades on G4 tower systems (non-MDD only)

I'm in a discussion on another forum right now about this and I'd like some additional input.  Have any of you successfully installed a third-party dual-CPU upgrade in a pre-MDD G4 tower AND had it enabled dual under OS9?

  There was a well-established issue with the stock Apple multiprocessing extension causing a freeze during startup (among various other bizarre issues of their own even on stock systems).  The file would either be removed, making it run single-processor, or be patched.  With the MDD systems this was officially rectified by Sonnet with a hacked version of the "Apple CPU Plugins" file.  In my case this even worked to the extent that the OS9Lives universal 9.2.2 system restore will allow a FW800 model to boot 9.2.2 with the Sonnet MDX dual 1.8GHz fully enabled, which is super-cool!!!

  My concern is with all of the earlier versions of the G4 towers from Sawtooth through Quicksilver when paired with dual G4 chips of 7447 type and later.  The Sonnet installer and firmware updater was supposed to patch the CPU Plugins file, but often wouldn't without any error message.  This seemed to stem from the large number of versions of the file issued by Apple - the patcher wouldn't recognize some of them properly.  (To compound the situation, and cause widespread confusion, one revision of the Sawtooth motherboard is fully incompatible with multiple CPU modules.)

  I'm wondering what ever worked dual properly with these systems and third-party upgrades.  I only have a Giga Designs 7447a dual 1.8GHz to test with.  My Quicksilver (first revision) already has this installed and working under 10.4 and 10.5.  So far during my testing it only works single in OS9.2.2 (albeit super-fast!).  My two Sawtooths were never in consideration for upgrade prior, but I would now like to see what happens.  (First I have to check their revisions.)

  So, simply put, do any of you have a machine working third-party-dual in the Sawtooth through Quicksilver range under OS9.x?  If so, what manufacturer and chip type - pre-7447 or 7447-or-later?  What software did you have to use to make it function?


Board footer

About ThinkClassic

ThinkClassic specialises in the use, maintenance, repair, restoration and modification of vintage computers and peripherals.