You are not logged in.

#1 2017-10-31 19:52:49

silasqwerty1
Member
Registered: 2017-10-31
Posts: 2

Macintosh 512ke Not Starting Up

Hello! I recently got an old Macintosh 512ke and it is not starting up. I hear what seems to be the startup sound, but the only thing to show up on the screen is the cursor and a floppy disk with a blinking question mark in the middle. As far as I can tell, it seems to need a new hard drive/boot floppy. I don't have any other computers capable of writing an 800kb mac format disk. I did not get a mouse with it, and the battery in the back had to be removed due to "minor" leakage, could that be an issue? Thank you in advance!

Offline

#2 2017-11-01 07:44:09

LCGuy
Administrator
From: Sydney, Australia
Registered: 2014-05-13
Posts: 821

Re: Macintosh 512ke Not Starting Up

The blinking question mark is actually a good sign, it means that the machine is actually, indeed working. These machines don't have a built in hard disk, internal HDDs weren't a factory option until the Mac SE and Mac II in 1987. You will need a boot disk to get the machine to work, if you don't have another machine that can write 800k disks, or a friend who does, you can buy a boot disk here. Or better yet, spend a bit more money and buy a Floppy Emu (available from the same site), which will allow you to boot and run software on the machine via images stored on a microSD card.

Offline

#3 2017-11-10 17:53:29

silasqwerty1
Member
Registered: 2017-10-31
Posts: 2

Re: Macintosh 512ke Not Starting Up

Thank you very much! A few floppies came with it, but as far as I can tell none are bootable. I don't have the cash for a floppy emu at the moment, but buying a boot disk looks like a possible option. Good to know that everything appears to work at least!

Offline

Board footer

About ThinkClassic

ThinkClassic specialises in the maintenance, repair, restoration and modification of Vintage Apple and Macintosh computers. Ask questions and find answers about classic Apple desktops, laptops, accessories and peripherals.